summary refs log tree commit diff
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2019-10-26 23:11:07 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-28 11:28:59 +0100
commit6bb93af8553c746e50934792f3969f2e72013a14 (patch)
tree29931d61dcdcaf7c5fd5b3d19c75f762df081a05
parented79636c8b2c1e59a4ba2c5c0f3b561fbe15b025 (diff)
downloadguix-6bb93af8553c746e50934792f3969f2e72013a14.tar.gz
gnu: profanity: Add configure flags for better defaults.
* gnu/packages/messaging.scm (profanity)[arguments]<#configure-flags>:
Add --enable-omemo, --enable-notifications and --enable-icon,
[native-inputs]: add libnotify and libsignal-protocol-c.

Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
-rw-r--r--gnu/packages/messaging.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index f890ad8dd5..b56a3e92cb 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1627,6 +1627,11 @@ are both supported).")
                (base32
                 "0nxh81j8ky0fzv47pip1jb7rs5rrin3jx0f3h632bvpjiya45r1z"))))
     (build-system gnu-build-system)
+    (arguments
+     '(#:configure-flags
+       (list "--enable-omemo"
+             "--enable-icons"
+             "--enable-notifications")))
     (inputs
      `(("curl" ,curl)
        ("expat" ,expat)
@@ -1642,7 +1647,10 @@ are both supported).")
        ("autoconf-archive" ,autoconf-archive)
        ("automake" ,automake)
        ("cmocka" ,cmocka)
+       ("gtk+" ,gtk+-2)
+       ("libnotify" ,libnotify)
        ("libtool" ,libtool)
+       ("libsignal-protocol-c" ,libsignal-protocol-c)
        ("pkg-config" ,pkg-config)))
     (synopsis "Console-based XMPP client")
     (description "Profanity is a console based XMPP client written in C