summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-02-02 15:39:02 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-02-02 15:49:17 +0100
commit72fabd8d6ef7fbfd19c1f1ef294b26e3c5a16bbf (patch)
treedbc68fc7c050a67569972a9fa27751ee4ecd0f25
parenta6e47aaa9feb2a3cc59bd25d7839f67caada5d35 (diff)
downloadguix-72fabd8d6ef7fbfd19c1f1ef294b26e3c5a16bbf.tar.gz
gnu: xbindkeys: Refer to tk's wish interpreter.
Fixes <http://issues.guix.gnu.org/46255>.

* gnu/packages/xdisorg.scm (xbindkeys)[arguments]: Add a ‘sanitise-shebang’
phase.
[inputs]: Add tk.
-rw-r--r--gnu/packages/xdisorg.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 26f60a31a4..4d1dc8391c 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -105,6 +105,7 @@
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages sphinx)
+  #:use-module (gnu packages tcl)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages)
@@ -954,11 +955,23 @@ transparent text on your screen.")
                (base32
                 "1wl2vc5alisiwyk8m07y1ryq8w3ll9ym83j27g4apm4ixjl8d6x2"))))
     (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'sanitise-shebang
+           ;; This wish script uses a strange double shebang that escapes our
+           ;; patch-shebangs phase.  Assume that it's unnecessary & replace it.
+           (lambda _
+             (substitute* "xbindkeys_show"
+               (("^#!.*|^exec wish.*") "")
+               (("^# \\\\") (string-append "#!" (which "wish"))))
+             #t)))))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs
      `(("guile" ,guile-2.2)
-       ("libx11" ,libx11)))
+       ("libx11" ,libx11)
+       ("tk" ,tk)))
     (home-page "https://www.nongnu.org/xbindkeys/")
     (synopsis "Associate a combination of keys with a shell command")
     (description