summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-12-19 15:34:47 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-12-19 15:36:40 +0100
commit74471036f63d5b4d578cd79972221100d992d7e1 (patch)
tree47443da8fd1fa665865ef1bbc619133c6e20160b
parent445013b69da3d2eb10ebb145d5d55ee62aa155ed (diff)
downloadguix-74471036f63d5b4d578cd79972221100d992d7e1.tar.gz
gnu: behave: Fix tests.
* gnu/packages/check.scm (behave): Add missing directory to PYTHONPATH before
tests.
-rw-r--r--gnu/packages/check.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index c0cb4ae7fd..6619142b50 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1962,7 +1962,15 @@ backported from Python 2.7 for Python 2.4+.")
        ("python-parse" ,python-parse)
        ("python-parse-type" ,python-parse-type)))
     (arguments
-     '(#:test-target "behave_test"))
+     '(#:test-target "behave_test"
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'fix-library-loading
+           (lambda _
+             ;; Otherwise, tests fail with no module named 'path'
+             (setenv "PYTHONPATH" (string-append (getenv "PYTHONPATH") ":"
+                                                 (getcwd) "/tasks/_vendor"))
+             #t)))))
     (home-page "https://github.com/behave/behave")
     (synopsis "Python behavior-driven development")
     (description