summary refs log tree commit diff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-08 22:45:55 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-09 17:19:17 +0300
commit75a0cab4a1e49ea46c1cace63efa40c3ad94143a (patch)
treebd964c111300308f56968c97cfb8a165d39bf207
parent4ca2f9d86fb441bd643112c1be1fcd9bea121954 (diff)
downloadguix-75a0cab4a1e49ea46c1cace63efa40c3ad94143a.tar.gz
gnu: Add go-github-com-huandu-xstrings.
* gnu/packages/golang.scm (go-github-com-huandu-xstrings): New variable.
-rw-r--r--gnu/packages/golang.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 6589a1d743..c64d5dcfc5 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4336,4 +4336,26 @@ semantic versions.  Specifically it provides the ability to:
 @item Optionally work with a @code{v} prefix
 @end itemize\n")
     (license license:expat)))
+
+(define-public go-github-com-huandu-xstrings
+  (package
+    (name "go-github-com-huandu-xstrings")
+    (version "1.3.2")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/huandu/xstrings")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0pwar6rc0fqb6pll38a44s81g5kb65vbg71jg5lx8caphjnikq5r"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "github.com/huandu/xstrings"))
+    (home-page "https://github.com/huandu/xstrings/")
+    (synopsis "Collection of string functions")
+    (description "Go package xstrings is a collection of string functions,
+which are widely used in other languages but absent in Go package strings.")
+    (license license:expat)))
     (license license:expat)))