summary refs log tree commit diff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-04-12 16:18:12 -0400
committerMark H Weaver <mhw@netris.org>2015-04-12 17:26:39 -0400
commit866f469eddb6a28cfdbc3b2eec3d3a6a241f7168 (patch)
tree847c2c0449fd9996c2260ba7399a5f9ec4031aa2
parent7ae3e06a322cc1801cecd90ae01eb811800a02cd (diff)
downloadguix-866f469eddb6a28cfdbc3b2eec3d3a6a241f7168.tar.gz
gnu: gnutls: Update to 3.4.0.
* gnu/packages/patches/gnutls-fix-duplicate-manpages.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/gnutls.scm (gnutls)[source]: Update to 3.4.0.  Add patch.
  [arguments]: Pass --without-p11-kit to 'configure'.
  [propagated-inputs]: Use 'nettle' instead of 'nettle-2'.  Add 'libidn'.
-rw-r--r--gnu-system.am1
-rw-r--r--gnu/packages/gnutls.scm16
-rw-r--r--gnu/packages/patches/gnutls-fix-duplicate-manpages.patch30
3 files changed, 43 insertions, 4 deletions
diff --git a/gnu-system.am b/gnu-system.am
index 8ad58d0eaa..f28cd145ee 100644
--- a/gnu-system.am
+++ b/gnu-system.am
@@ -427,6 +427,7 @@ dist_patch_DATA =						\
   gnu/packages/patches/glibc-ldd-x86_64.patch			\
   gnu/packages/patches/glibc-locales.patch			\
   gnu/packages/patches/gmp-arm-asm-nothumb.patch		\
+  gnu/packages/patches/gnutls-fix-duplicate-manpages.patch	\
   gnu/packages/patches/gobject-introspection-absolute-shlib-path.patch \
   gnu/packages/patches/gobject-introspection-cc.patch		\
   gnu/packages/patches/gobject-introspection-girepository.patch	\
diff --git a/gnu/packages/gnutls.scm b/gnu/packages/gnutls.scm
index c55124cb67..8e8dc400bf 100644
--- a/gnu/packages/gnutls.scm
+++ b/gnu/packages/gnutls.scm
@@ -29,6 +29,7 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages libffi)
+  #:use-module (gnu packages libidn)
   #:use-module (gnu packages nettle)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
@@ -103,7 +104,7 @@ living in the same process.")
 (define-public gnutls
   (package
     (name "gnutls")
-    (version "3.3.14")
+    (version "3.4.0")
     (source (origin
              (method url-fetch)
              (uri
@@ -114,7 +115,9 @@ living in the same process.")
                              "/gnutls-" version ".tar.xz"))
              (sha256
               (base32
-               "0lpcgkp8bb1b7f9z935f7h9c0srd4fc52404x70hk2ddz8q01yhd"))))
+               "0bj7ydvsyvml59b6040wg7694iz37rwnqnv09bic9ddz652588ml"))
+             (patches
+              (list (search-patch "gnutls-fix-duplicate-manpages.patch")))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags
@@ -130,7 +133,11 @@ living in the same process.")
              ;; store is used, so each program has to provide its own
              ;; fallback, and users have to configure each program
              ;; independently.  This seems suboptimal.
-             "--with-default-trust-store-dir=/etc/ssl/certs")))
+             "--with-default-trust-store-dir=/etc/ssl/certs"
+
+             ;; FIXME: Temporarily disable p11-kit support since it is not
+             ;; working on mips64el.
+             "--without-p11-kit")))
     (outputs '("out" "debug"))
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -141,7 +148,8 @@ living in the same process.")
     (propagated-inputs
      ;; These are all in the 'Requires.private' field of gnutls.pc.
      `(("libtasn1" ,libtasn1)
-       ("nettle" ,nettle-2)
+       ("libidn" ,libidn)
+       ("nettle" ,nettle)
        ("zlib" ,zlib)))
     (home-page "http://www.gnu.org/software/gnutls/")
     (synopsis "Transport layer security library")
diff --git a/gnu/packages/patches/gnutls-fix-duplicate-manpages.patch b/gnu/packages/patches/gnutls-fix-duplicate-manpages.patch
new file mode 100644
index 0000000000..95a25560e5
--- /dev/null
+++ b/gnu/packages/patches/gnutls-fix-duplicate-manpages.patch
@@ -0,0 +1,30 @@
+Remove duplicate manpage entries from Makefile.
+
+--- gnutls-3.4.0/doc/manpages/Makefile.am.orig	2015-04-06 04:48:30.000000000 -0400
++++ gnutls-3.4.0/doc/manpages/Makefile.am	2015-04-12 16:52:58.029694525 -0400
+@@ -134,11 +134,8 @@
+ APIMANS += gnutls_certificate_get_peers_subkey_id.3
+ APIMANS += gnutls_certificate_get_trust_list.3
+ APIMANS += gnutls_certificate_get_verify_flags.3
+-APIMANS += gnutls_certificate_get_verify_flags.3
+-APIMANS += gnutls_certificate_get_x509_crt.3
+ APIMANS += gnutls_certificate_get_x509_crt.3
+ APIMANS += gnutls_certificate_get_x509_key.3
+-APIMANS += gnutls_certificate_get_x509_key.3
+ APIMANS += gnutls_certificate_send_x509_rdn_sequence.3
+ APIMANS += gnutls_certificate_server_set_request.3
+ APIMANS += gnutls_certificate_set_dh_params.3
+--- gnutls-3.4.0/doc/manpages/Makefile.in.orig	2015-04-08 02:08:30.000000000 -0400
++++ gnutls-3.4.0/doc/manpages/Makefile.in	2015-04-12 16:53:13.319694530 -0400
+@@ -1275,11 +1275,8 @@
+ 	gnutls_certificate_get_peers_subkey_id.3 \
+ 	gnutls_certificate_get_trust_list.3 \
+ 	gnutls_certificate_get_verify_flags.3 \
+-	gnutls_certificate_get_verify_flags.3 \
+-	gnutls_certificate_get_x509_crt.3 \
+ 	gnutls_certificate_get_x509_crt.3 \
+ 	gnutls_certificate_get_x509_key.3 \
+-	gnutls_certificate_get_x509_key.3 \
+ 	gnutls_certificate_send_x509_rdn_sequence.3 \
+ 	gnutls_certificate_server_set_request.3 \
+ 	gnutls_certificate_set_dh_params.3 \