summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-09-21 20:45:47 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-09-27 21:26:14 +0200
commit88b1533c27cdfca98556e6ccb4aff3ce5346ad3c (patch)
treeb9ae4dc37bcbfe3ca5c37449caf1c9fb6b761b45
parent9c5dbbf0cebe8aea9892ebdf24eb8f19db8e13fa (diff)
downloadguix-88b1533c27cdfca98556e6ccb4aff3ce5346ad3c.tar.gz
gnu: Add ocaml-uuidm.
* gnu/packages/ocaml.scm (ocaml-uuidm): New variable.
-rw-r--r--gnu/packages/ocaml.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 0ba236414c..f49deb67a4 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3361,6 +3361,36 @@ cpp-like directives.")
 tool and piqi-ocaml.")
     (license license:asl2.0)))
 
+(define-public ocaml-uuidm
+  (package
+    (name "ocaml-uuidm")
+    (version "0.9.6")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://erratique.ch/software/uuidm/"
+                                  "releases/uuidm-" version ".tbz"))
+              (sha256
+               (base32
+                "0hz4fdx0x16k0pw9995vkz5d1hmzz6b16wck9li399rcbfnv5jlc"))))
+    (build-system ocaml-build-system)
+    (arguments
+     `(#:build-flags
+       (list "build" "--tests" "true" "--with-cmdliner" "true")
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))
+    (native-inputs
+     `(("opam" ,opam)))
+    (propagated-inputs
+     `(("cmdliner" ,ocaml-cmdliner)
+       ("topkg" ,ocaml-topkg)))
+    (home-page "http://erratique.ch/software/uuidm")
+    (synopsis "Universally unique identifiers for OCaml")
+    (description "Uuidm is an OCaml module implementing 128 bits universally
+unique identifiers (UUIDs) version 3, 5 (named based with MD5, SHA-1 hashing)
+and 4 (random based) according to RFC 4122.")
+    (license license:isc)))
+
 (define-public coq-flocq
   (package
     (name "coq-flocq")