summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-09-03 19:51:43 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-09-03 23:31:35 +0200
commit8cc6a876bd8c0b18bc7849d9398c87e34e9e10c3 (patch)
tree33365ad17d1e2d92ba3a7fd15e86f9c5548693b5
parentf082c78c98d8fee4acd89dd40081c7fd7a081b74 (diff)
downloadguix-8cc6a876bd8c0b18bc7849d9398c87e34e9e10c3.tar.gz
gnu: ocaml-migrate-parsetree: Update to 1.4.0.
* gnu/packages/ocaml.scm (ocaml-migrate-parsetree): Update to 1.4.0.
(ocaml-ppx-tools-versioned): Update to 5.2.3.
[source]: Use git-fetch.
(ocaml-bisect-ppx): Fix compilation error.
-rw-r--r--gnu/packages/ocaml.scm30
1 files changed, 21 insertions, 9 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index af10411f88..5921d4ea9c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1347,7 +1347,7 @@ following a very simple s-expression syntax.")
 (define-public ocaml-migrate-parsetree
   (package
     (name "ocaml-migrate-parsetree")
-    (version "1.2.0")
+    (version "1.4.0")
     (home-page "https://github.com/ocaml-ppx/ocaml-migrate-parsetree")
     (source
      (origin
@@ -1358,7 +1358,7 @@ following a very simple s-expression syntax.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "16kas19iwm4afijv3yxd250s08absabmdcb4yj57wc8r4fmzv5dm"))))
+         "0sv1p4615l8gpbah4ya2c40yr6fbvahvv3ks7zhrsgcwcq2ljyr2"))))
     (build-system dune-build-system)
     (arguments
      `(#:tests? #f))
@@ -1376,16 +1376,16 @@ functions to the next and/or previous version.")
 (define-public ocaml-ppx-tools-versioned
   (package
     (name "ocaml-ppx-tools-versioned")
-    (version "5.2.1")
+    (version "5.2.3")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/ocaml-ppx/"
-                                  "ppx_tools_versioned/archive/"
-                                  version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/ocaml-ppx/ppx_tools_versioned")
+                     (commit version)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1x2xfjpkzbcz4rza1d7gh3ipliw6jqfcklbsln82v3561qgkqgmh"))))
+                "1hcmpnw26zf70a71r3d2c2c0mn8q084gdn1r36ynng6fv9hq6j0y"))))
     (build-system dune-build-system)
     (arguments
      `(#:test-target "."))
@@ -5077,6 +5077,18 @@ combinators.")
      `(("ocaml-migrate-parsetree" ,ocaml-migrate-parsetree)
        ("ocaml-ppx-tools-versioned" ,ocaml-ppx-tools-versioned)
        ("ocaml-ounit" ,ocaml-ounit)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'fix-deprecated
+           (lambda _
+             ;; Fixed upstream in 22dd1ad9a0c9629f60599c22d82c6488394d6d32, but
+             ;; not in a release yet.
+             (substitute* "src/ppx/instrument.ml"
+               (("module Ast = Ast_405")
+                "module Ast = Migrate_parsetree.Ast_405
+module Ast_405 = Ast"))
+             #t)))))
     (home-page "https://github.com/aantron/bisect_ppx")
     (synopsis "Code coverage for OCaml")
     (description "Bisect_ppx helps you test thoroughly.  It is a small