summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 10:52:48 +0100
committerDavid Craven <david@craven.ch>2017-01-04 16:05:25 +0100
commit93eeadf0226078a6a9ecf57f84446044b4be249b (patch)
treefab66536fa44b3d0e863eed973b52a91f4462c41
parentbc2c3bc627874eb201c15ea7356af27eecb2ae1c (diff)
downloadguix-93eeadf0226078a6a9ecf57f84446044b4be249b.tar.gz
gnu: Add ocamlmod.
* gnu/packages/ocaml.scm (ocamlmod): New variable.

Signed-off-by: David Craven <david@craven.ch>
-rw-r--r--gnu/packages/ocaml.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 01587bbe7c..6a12cb45ee 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -813,3 +813,23 @@ other XUnit testing frameworks.")
 JAR format.  It provides functions for reading from and writing to compressed
 files in these formats.")
     (license license:lgpl2.1+)))
+
+(define-public ocamlmod
+  (package
+    (name "ocamlmod")
+    (version "0.0.8")
+    (source (origin
+              (method url-fetch)
+              (uri (ocaml-forge-uri name version 1544))
+              (sha256
+               (base32
+                "1w0w8lfyymvk300dv13gvhrddpcyknvyp4g2yvq2vaw7khkhjs9g"))))
+    (build-system ocaml-build-system)
+    (native-inputs
+     `(("ounit" ,ocaml-ounit)))
+    (arguments
+     `(#:tests? #f)) ; tests are done during build
+    (home-page "https://forge.ocamlcore.org/projects/ocamlmod")
+    (synopsis "Generate modules from OCaml source files")
+    (description "Generate modules from OCaml source files.")
+    (license license:lgpl2.1+))) ; with an exception