summary refs log tree commit diff
diff options
context:
space:
mode:
authorValentin Ignatev <valentignatev@gmail.com>2020-01-19 16:15:06 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-02-23 22:23:10 +0200
commit94ddb94acc0ff2a8a4a06ccbd4b02cf3a9042a48 (patch)
treefadda9bc2bdaf88788619f5c129e4197f3094fb0
parent791a8e533115c2b8633d3ab7d2f773dad7494d9b (diff)
downloadguix-94ddb94acc0ff2a8a4a06ccbd4b02cf3a9042a48.tar.gz
gnu: Add rust-vswhom-sys-0.1.
* gnu/packages/crates-io.scm (rust-vswhom-sys-0.1): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 1bbde4342f..cfde654185 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -16287,6 +16287,30 @@ updated when the crate version changes.")
      "The uninhabited void type for use in statically impossible cases.")
     (license license:expat)))
 
+(define-public rust-vswhom-sys-0.1
+  (package
+    (name "rust-vswhom-sys")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "vswhom-sys" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0clm4dx4amwlhg5lkh52fmvvwq6c7s7b9xqljw39mryhsc158bzw"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-libc" ,rust-libc-0.2)
+        ("rust-cc" ,rust-cc-1.0))))
+    (home-page "https://github.com/nabijaczleweli/vswhom-sys.rs")
+    (synopsis "Pure FFI to Jon Blow's VS discovery script")
+    (description
+     "This package provides a pure FFI to Jon Blow's VS discovery script.")
+    (license license:expat)))
+
 (define-public rust-vte-0.3
   (package
     (name "rust-vte")