summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-09-21 23:52:00 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-09-23 00:21:38 +0200
commit9576469cc6e1df4d939632473eb73e9598d59ac6 (patch)
treece42a84ae379ca6b3e24b0261a4c3cddd70c9636
parent8acb81ba711197d11b35fe9dbe0550fc07f4b782 (diff)
downloadguix-9576469cc6e1df4d939632473eb73e9598d59ac6.tar.gz
gnu: Add rust-fs-utils-1.
* gnu/packages/crates-io.scm (rust-fs-utils-1): New variable.
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 61ef325aad..d6e3ff1ed0 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -23263,6 +23263,29 @@ helpful error messages.")
 process and much more.")
     (license license:expat)))
 
+(define-public rust-fs-utils-1
+  (package
+    (name "rust-fs-utils")
+    (version "1.1.4")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "fs-utils" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "14r5wl14mz227v0lpy89lvjzfnxgdxigvrrmm6c4r52w03fakivg"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-quick-error" ,rust-quick-error-1))
+       #:cargo-development-inputs
+       (("rust-tempfile" ,rust-tempfile-3))))
+    (home-page "https://github.com/Byron/fs-utils-rs")
+    (synopsis "Utilities to help working with the filesytem")
+    (description "This package provides a bunch of utilities to help working
+with the filesytem.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-fs2-0.2
   (package
     (name "rust-fs2")