summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-11-24 23:05:30 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-11-27 00:49:52 +0100
commit97bb46ea0e5f9744957b06d4e67e3b34ef9a64d3 (patch)
tree00fd2133db27dc56c0d3726412dfa4f94e145e62
parent1cf22254b089346ad3a3b2a67ebf0c6f42395b11 (diff)
downloadguix-97bb46ea0e5f9744957b06d4e67e3b34ef9a64d3.tar.gz
gnu: eid-mw: Disable pinentry.
* gnu/packages/security-token.scm (eid-mw)[arguments]:
Add "--disable-pinentry" to #:configure-flags.
-rw-r--r--gnu/packages/security-token.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index e006b4cf25..ac6aa2bdbe 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -145,7 +145,12 @@ readers and is needed to communicate with such devices through the
        ("cyrus-sasl" ,cyrus-sasl)))
     (arguments
      `(#:configure-flags
-       (list "--disable-static")
+       (list "--disable-static"
+
+             ;; With the (prettier) pinentry enabled, eid-viewer will skip
+             ;; crucial dialogue when used with card readers with built-in
+             ;; keypads such as the Digipass 870, and possibly others too.
+             "--disable-pinentry")
        #:phases
        (modify-phases %standard-phases
          (replace 'bootstrap