summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-09-19 22:05:18 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-09-22 07:34:43 +0200
commit9f391b90faca02ca97c5018d6c095ecdaa1a94a7 (patch)
tree89b143ef05fc8dd418224e03090073f4bbbcad43
parent9140a4dd1d449f9df02d3c26a211ca335bacff14 (diff)
downloadguix-9f391b90faca02ca97c5018d6c095ecdaa1a94a7.tar.gz
gnu: coq-interval: Update to 4.5.2.
* gnu/packages/coq.scm (coq-interval): Update to 4.5.2.
-rw-r--r--gnu/packages/coq.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index cd864e962f..f487b3794c 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -463,7 +463,7 @@ provides BigN, BigZ, BigQ that used to be part of Coq standard library.")
 (define-public coq-interval
   (package
     (name "coq-interval")
-    (version "4.4.0")
+    (version "4.5.2")
     (source
      (origin
        (method git-fetch)
@@ -473,7 +473,7 @@ provides BigN, BigZ, BigQ that used to be part of Coq standard library.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "1rlcbv1nqm7zv60n63lca6nnxcq3c18akgzl72s1n3h89gvhs87z"))))
+         "138vgb0bq6wkygrhkahjgb9spwpzc6x6kkycj2qnf5naxx1z412w"))))
     (build-system gnu-build-system)
     (native-inputs
      (list autoconf automake ocaml which coq))
@@ -486,7 +486,9 @@ provides BigN, BigZ, BigQ that used to be part of Coq standard library.")
     (arguments
      `(#:configure-flags
        (list (string-append "COQUSERCONTRIB=" (assoc-ref %outputs "out")
-                            "/lib/coq/user-contrib"))
+                            "/lib/coq/user-contrib")
+             (string-append "OCAMLFIND_DESTDIR=" (assoc-ref %outputs "out")
+                            "/lib/ocaml/site-lib"))
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'fix-remake