summary refs log tree commit diff
diff options
context:
space:
mode:
authorAdrian Fullmer <adrianfullmer@yahoo.com>2020-03-14 11:59:58 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-07-14 09:02:09 -0400
commita6a4d4b843e8fcf35009ca556d9ed25a700b52d5 (patch)
tree47003108616ca458c971bb5be80847b9b57c58d3
parent073904c5536c73a71aa42347453cb18ae41a6b19 (diff)
downloadguix-a6a4d4b843e8fcf35009ca556d9ed25a700b52d5.tar.gz
gnu: bitlbee-discord: Fix build.
* gnu/packages/messaging.scm (bitlbee-discord)[phases]{configure}: Delete
override and move the configure flags to...
[configure-flags]: ... here.  Specify the '--with-bdatadir' configure flag,
which resolves a build failure.

Co-authored-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
-rw-r--r--gnu/packages/messaging.scm15
1 files changed, 6 insertions, 9 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 22e1c370aa..55c12c8e9a 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -592,20 +592,17 @@ identi.ca and status.net).")
         (base32 "02pigk2vbz0jdz11f96sygdvp1j762yjn62h124fkcsc070g7a2f"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:phases
+     `(#:configure-flags
+       (let ((out (assoc-ref %outputs "out")))
+         (list (string-append "--with-bdatadir=" out "/share/bitlbee/")
+               (string-append "--with-plugindir=" out "/lib/bitlbee/")))
+       #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-autogen
            (lambda _
              (let ((sh (which "sh")))
                (substitute* "autogen.sh" (("/bin/sh") sh))
-               (setenv "CONFIG_SHELL" sh))
-             #t))
-         (replace 'configure
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (invoke "./configure"
-                     (string-append "--with-plugindir="
-                                    (assoc-ref outputs "out")
-                                    "/lib/bitlbee/")))))))
+               (setenv "CONFIG_SHELL" sh)))))))
     (inputs `(("glib" ,glib)))
     (native-inputs `(("pkg-config" ,pkg-config)
                      ("autoconf" ,autoconf)