summary refs log tree commit diff
diff options
context:
space:
mode:
authorMekeor Melire <mekeor.melire@gmail.com>2017-03-02 23:31:50 +0100
committerLeo Famulari <leo@famulari.name>2017-03-15 17:17:06 -0400
commita829c6501be67b700df4d95258e8593224f68000 (patch)
treeb3133a452063296ea85908f9de1a7e54266bcfe7
parent781d3b070cab20caf33a2b9ac8d48b3221622fab (diff)
downloadguix-a829c6501be67b700df4d95258e8593224f68000.tar.gz
gnu: Add profanity.
* gnu/packages/messaging.scm (profanity): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/messaging.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 493b18b666..559138ff39 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -44,6 +44,7 @@
   #:use-module (gnu packages base)
   #:use-module (gnu packages check)
   #:use-module (gnu packages crypto)
+  #:use-module (gnu packages curl)
   #:use-module (gnu packages cyrus-sasl)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages documentation)
@@ -1293,4 +1294,38 @@ are both supported).")
     ;; Dual licensed.
     (license (list license:gpl3+ license:x11))))
 
+(define-public profanity
+    (package
+        (name "profanity")
+        (version "0.5.1")
+        (source (origin
+                  (method url-fetch)
+                  (uri "http://www.profanity.im/profanity-0.5.1.tar.gz")
+                  (sha256
+                   (base32
+                     "1f7ylw3mhhnii52mmk40hyc4kqhpvjdr3hmsplzkdhsfww9kflg3"))))
+        (build-system gnu-build-system)
+        (inputs
+         `(("curl" ,curl)
+           ("expat" ,expat)
+           ("glib" ,glib)
+           ("gpgme" ,gpgme)
+           ("libmesode" ,libmesode)
+           ("libotr" ,libotr)
+           ("ncurses" ,ncurses)
+           ("openssl" ,openssl)
+           ("readline" ,readline)))
+        (native-inputs
+         `(("autoconf" ,autoconf)
+           ("autoconf-archive" ,autoconf-archive)
+           ("automake" ,automake)
+           ("cmocka" ,cmocka)
+           ("libtool" ,libtool)
+           ("pkg-config" ,pkg-config)))
+        (synopsis "Console-based XMPP client")
+        (description "Profanity is a console based XMPP client written in C
+using ncurses and libmesode, inspired by Irssi.")
+        (home-page "http://www.profanity.im")
+        (license license:gpl3+)))
+
 ;;; messaging.scm ends here