summary refs log tree commit diff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@inbox.ru>2017-05-08 20:55:49 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-05-09 17:51:49 +0200
commita8f25449114bd9035898eec3455db51c0f4d928d (patch)
treee8cdc0dd0b520471feb2a6912bcbfeba5c97941d
parentbc81e6cae40098684c14b10d0aa4c6257acbbdb6 (diff)
downloadguix-a8f25449114bd9035898eec3455db51c0f4d928d.tar.gz
gnu: sbcl: Add missing '#:modules' imports.
Fixes <https://bugs.gnu.org/26843>.

* gnu/packages/lisp.scm (sbcl): Add missing '#:modules' imports.

Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/lisp.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 2bbe398079..889073edba 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -284,7 +284,10 @@ an interpreter, a compiler, a debugger, and much more.")
        ("texlive" ,texlive)
        ("texinfo" ,texinfo)))
     (arguments
-     '(#:phases
+     '(#:modules ((guix build gnu-build-system)
+                  (guix build utils)
+                  (srfi srfi-1))
+       #:phases
        (modify-phases %standard-phases
          (delete 'configure)
          (add-before 'build 'patch-unix-tool-paths