summary refs log tree commit diff
diff options
context:
space:
mode:
authorRoman Riabenko <roman@riabenko.com>2022-04-11 13:34:39 +0300
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-04-12 20:31:33 +0200
commitb0f477b8a3487606b1c107c11eb31efbd52f5b63 (patch)
treeac3fae9f33d3c9527b769a26d3c36749157032ce
parent855097683230b756ba28636bed03ce904b6f3589 (diff)
downloadguix-b0f477b8a3487606b1c107c11eb31efbd52f5b63.tar.gz
gnu: games: Add robotfindskitten.
* gnu/packages/games.scm (robotfindskitten): New variable.

Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/games.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8cc29b3487..de398c297f 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -69,6 +69,7 @@
 ;;; Copyright © 2021 Christopher Baines <mail@cbaines.net>
 ;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
 ;;; Copyright © 2022 Yovan Naumovski <yovan@gorski.stream>
+;;; Copyright © 2022 Roman Riabenko <roman@riabenko.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2250,6 +2251,38 @@ utilizing the art assets from the @code{SuperTux} project.")
                      license:gpl2+
                      license:gpl3+)))))
 
+(define-public robotfindskitten
+  (package
+    (name "robotfindskitten")
+    (version "2.8284271.702")            ; 1600003_201b is older, see ChangeLog
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/" name "/" name
+                                  "/releases/download/" version "/"
+                                  name "-" version ".tar.gz"))
+              (sha256
+                (base32
+                 "1bwrkxm83r9ajpkd6x03nqvmdfpf5vz6yfy0c97pq3v3ykj74082"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:tests? #f                       ; there are no tests
+      #:make-flags
+      #~(list
+         ;; Required for colorized output, see <http://bugs.gnu.org/54607>.
+         "CFLAGS=-D_XOPEN_SOURCE=600"
+         (string-append "execgamesdir=" #$output "/bin"))))
+    (inputs (list ncurses))
+    (outputs (list "out" "debug"))
+    (synopsis "Thematic meditative game")
+    (description
+     "You are a robot moving around in a realm filled with ASCII characters.
+Examine humourously described though useless items as you search for a kitten
+among them.  The theme of this Zen simulation is continued in its
+documentation.")
+    (home-page "http://robotfindskitten.org/")
+    (license license:gpl2+)))
+
 (define-public roguebox-adventures
   (package
     (name "roguebox-adventures")