summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-11 11:02:48 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-11 13:51:40 +0300
commitbddad00bffc5837e89942756fa5b7234f63f1f47 (patch)
tree8067cc9cff244c070ca4a26c325e4705a1e7f572
parentee559bca27b09fe81f15bf5c9c55ad698ac3926b (diff)
downloadguix-bddad00bffc5837e89942756fa5b7234f63f1f47.tar.gz
gnu: Add ruby-yaml-lint.
* gnu/packages/ruby.scm (ruby-yaml-lint): New variable.
-rw-r--r--gnu/packages/ruby.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 77cfdca84d..7c2cf35ac2 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -11339,6 +11339,40 @@ indentation will probably be an issue and hence this gem.")
 YAML.load suitable for accepting user input in Ruby applications.")
     (license license:expat)))
 
+(define-public ruby-yaml-lint
+  (package
+    (name "ruby-yaml-lint")
+    (version "0.0.10")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/Pryz/yaml-lint")
+               (commit version)))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "1jz26mxjkdyjbgqp7f9isnzd1i6vkizsswyj1v639nmq31hwfh0d"))))
+    (build-system ruby-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "rspec"))
+             #t)))))
+    (native-inputs
+     `(("ruby-coveralls" ,ruby-coveralls)
+       ("ruby-rspec" ,ruby-rspec)
+       ("ruby-simplecov" ,ruby-simplecov)))
+    (synopsis "Simple YAML check tool")
+    (description
+     "@code{yaml-lint} will simply try to load the YAML file with the built-in
+Ruby yaml library.")
+    (home-page "https://github.com/Pryz/yaml-lint")
+    (license license:expat)))
+
 (define-public ruby-mercenary
   (package
     (name "ruby-mercenary")