summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-23 20:35:00 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-23 20:35:00 +0100
commitc0e7242aa18d9b88a1d737f0b22389b680d3ada7 (patch)
tree7c23a9285623def26e69c335fecb6d0f5d451dc7
parent19dc16ce4b9c5fa885b4641a174afb0e1e653a9f (diff)
downloadguix-c0e7242aa18d9b88a1d737f0b22389b680d3ada7.tar.gz
gnu: libgit2: Reintroduce 1.1.0.
* gnu/packages/version-control.scm (libgit2-1.1): New variable.
* gnu/packages/patches/libgit2-mtime-0.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/libgit2-mtime-0.patch14
-rw-r--r--gnu/packages/version-control.scm18
3 files changed, 33 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 351c81bb3a..6cc17b81a7 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1348,6 +1348,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/libcyaml-libyaml-compat.patch		\
   %D%/packages/patches/libexpected-nofetch.patch                \
   %D%/packages/patches/libgeotiff-adapt-test-script-for-proj-6.2.patch		\
+  %D%/packages/patches/libgit2-mtime-0.patch			\
   %D%/packages/patches/libgnome-encoding.patch			\
   %D%/packages/patches/libgnomeui-utf8.patch			\
   %D%/packages/patches/libgrss-CVE-2016-2001.patch		\
diff --git a/gnu/packages/patches/libgit2-mtime-0.patch b/gnu/packages/patches/libgit2-mtime-0.patch
new file mode 100644
index 0000000000..a6fdb50fff
--- /dev/null
+++ b/gnu/packages/patches/libgit2-mtime-0.patch
@@ -0,0 +1,14 @@
+The Clar test framework has a bug whereby it skips the parsing phase
+on files with mtime=0.
+
+Reported upstream at <https://github.com/vmg/clar/pull/78>.
+
+diff --git a/tests/generate.py b/tests/generate.py
+index b639c8f..111ca41 100644
+--- a/tests/generate.py
++++ b/tests/generate.py
+@@ -63,3 +63,3 @@ class Module(object):
+ 
+-        self.mtime = 0
++        self.mtime = None # Guix sets all file mtimes to '0'
+         self.enabled = True
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 5c5335ce15..a44c553c71 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -850,6 +850,24 @@ write native speed custom Git applications in any language with bindings.")
     ;; GPLv2 with linking exception
     (license license:gpl2)))
 
+(define-public libgit2-1.1
+  (package
+    (inherit libgit2)
+    (name "libgit2")
+    (version "1.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/libgit2/libgit2/"
+                                  "releases/download/v" version
+                                  "/libgit2-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1fjdglkh04qv3b4alg621pxa689i0wlf8m7nf2755zawjr2zhwxd"))
+              (patches (search-patches "libgit2-mtime-0.patch"))
+              (snippet '(begin
+                          (delete-file-recursively "deps") #t))
+              (modules '((guix build utils)))))))
+
 (define-public git-crypt
   (package
     (name "git-crypt")