summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-03-06 01:07:24 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-03-06 01:22:51 +0100
commitc8cbd369eb512b0bc5cc0d5dfc2b5d35da50aa4f (patch)
tree3737cd283254cd4406fb9c5ce7054de6958efb73
parent170cf035cece04fd2b9460451f5f66ba5c4485ca (diff)
downloadguix-c8cbd369eb512b0bc5cc0d5dfc2b5d35da50aa4f.tar.gz
gnu: vim-full: Remove duplicate 'make-flags'.
Fixes <https://bugs.gnu.org/46580>.

Co-authored-by: Tobias Geerinckx-Rice <me@tobias.gr>

* gnu/packages/vim.scm (vim-full)[arguments]: Remove duplicate
'make-flags'.

Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
-rw-r--r--gnu/packages/vim.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 372d470e09..d559364d32 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -9,6 +9,7 @@
 ;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2019, 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -216,11 +217,14 @@ with the editor vim.")))
              "--enable-xim"
              "--disable-selinux"
              "--enable-gui")
-       ;; This flag fixes the following error:
-       ;; .../libpython3.7m.a(pyexpat.o): undefined reference to symbol 'XML_FreeContentModel'
-       ;; .../libexpat.so.1: error adding symbols: DSO missing from command line
-       #:make-flags '("LDFLAGS=-lexpat")
        ,@(substitute-keyword-arguments (package-arguments vim)
+           ;; This flag fixes the following error:
+           ;; .../libpython3.7m.a(pyexpat.o): undefined reference to symbol 'XML_FreeContentModel'
+           ;; .../libexpat.so.1: error adding symbols: DSO missing from command line
+           ((#:make-flags flags)
+            `(append
+              (list "LDFLAGS=-lexpat")
+              (delete "CFLAGS=-D_REENTRANT" ,flags)))
            ((#:phases phases)
             `(modify-phases ,phases
                (add-before 'check 'start-xserver