summary refs log tree commit diff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-06-27 23:28:24 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-10-27 15:35:22 +0200
commitc969517cec2b403c13cb9150e12a4e6804b5326e (patch)
tree71875e6be0a5685789189b3546141515dd7b124d
parent0ad89a84c3e86093b4c17fd926a04cfc0228c6da (diff)
downloadguix-c969517cec2b403c13cb9150e12a4e6804b5326e.tar.gz
gnu: Add r-bader.
* gnu/packages/bioconductor.scm (r-bader): New variable.
-rw-r--r--gnu/packages/bioconductor.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 2e13a86774..111785800f 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -2404,6 +2404,30 @@ Nimblegen, cDNA, etc.).  Note that BAC does not deal with normalization, so
 you will have to normalize your data beforehand.")
     (license license:artistic2.0)))
 
+(define-public r-bader
+  (package
+    (name "r-bader")
+    (version "1.34.0")
+    (source (origin
+              (method url-fetch)
+              (uri (bioconductor-uri "BADER" version))
+              (sha256
+               (base32
+                "0i5x1r2ns1hxhqk5jyfqird81hck1hllvvgx5bn0rb5vl99g8spm"))))
+    (properties `((upstream-name . "BADER")))
+    (build-system r-build-system)
+    (home-page "https://bioconductor.org/packages/BADER")
+    (synopsis
+     "Bayesian analysis of differential expression in RNA sequencing data")
+    (description
+     "The BADER package is intended for the analysis of RNA sequencing data.
+The algorithm fits a Bayesian hierarchical model for RNA sequencing count
+data.  BADER returns the posterior probability of differential expression for
+each gene between two groups A and B.  The joint posterior distribution of the
+variables in the model can be returned in the form of posterior samples, which
+can be used for further down-stream analyses such as gene set enrichment.")
+    (license license:gpl2)))
+
 (define-public r-biocversion
   (package
     (name "r-biocversion")