summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-14 11:23:29 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-14 12:19:44 +0200
commitcbddff6d703117748d87a110e05a9a82dc725b0b (patch)
tree08095bcf1dfa88eeb603388ea21e3445153019d1
parent5e44ec69d68bf9bacfd7343e6ee78b25de1733fd (diff)
downloadguix-cbddff6d703117748d87a110e05a9a82dc725b0b.tar.gz
gnu: Add perl-lingua-en-sentence.
* gnu/packages/perl.scm (perl-lingua-en-sentence): New variable.
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index b164796e99..782963e2b5 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5723,6 +5723,28 @@ that aims to be compatible with the Uniforum message translations system as
 implemented for example in GNU gettext.")
     (license gpl3+)))
 
+(define-public perl-lingua-en-sentence
+  (package
+    (name "perl-lingua-en-sentence")
+    (version "0.31")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/K/KI/KIMRYAN/"
+                           "Lingua-EN-Sentence-" version ".tar.gz"))
+       (sha256
+        (base32 "11hlg92khd2azbxndnffsj9lggbxb3lqfdbwc6asr1c9lxlqddms"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-module-build" ,perl-module-build)))
+    (home-page "https://metacpan.org/release/Lingua-EN-Sentence")
+    (synopsis "Split text into sentences")
+    (description
+     "The Lingua::EN::Sentence module contains the function get_sentences,
+which splits text into its constituent sentences, based on a regular
+expression and a list of abbreviations (built in and given).")
+    (license perl-license)))
+
 (define-public perl-lingua-translit
   (package
     (name "perl-lingua-translit")