summary refs log tree commit diff
diff options
context:
space:
mode:
authorValentin Ignatev <valentignatev@gmail.com>2020-01-15 03:24:17 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-02-09 11:13:44 +0200
commitccdc86338d4ab95895581989093803deb36f8a50 (patch)
tree2d3edd0758720d0c9799652214830d3c23ebe3ba
parent835c854b5dcbded8e5893cdf1bd7d126f77a833c (diff)
downloadguix-ccdc86338d4ab95895581989093803deb36f8a50.tar.gz
gnu: Add rust-assert-matches-1.3.
* gnu/packages/crates-io.scm (rust-assert-matches-1.3): New variable.
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3ad193190f..c1844b9811 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -478,6 +478,26 @@ ArrayVec and ArrayString.")
      "ASCII-only equivalents to @code{char}, @code{str} and @code{String}.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-assert-matches-1.3
+  (package
+    (name "rust-assert-matches")
+    (version "1.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "assert_matches" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1rar61v00gz2aniid0mylxcr4q98s6l77c3hvbszmg57kj10msvx"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/murarth/assert_matches")
+    (synopsis "Asserts that a value matches a pattern")
+    (description
+     "This package asserts that a value matches a pattern in Rust.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-atty-0.2
   (package
     (name "rust-atty")