summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-09-16 14:35:05 +0200
committerMarius Bakke <marius@gnu.org>2021-09-16 23:26:58 +0200
commitce0d39ae2b8084392f4dee61ef976b1a5270014c (patch)
treef2d732b2dc98aecc92fdf49ab68a88a4cfc83680
parent9f4bb5f1893ba52a67b221c17fe23d69684418aa (diff)
downloadguix-ce0d39ae2b8084392f4dee61ef976b1a5270014c.tar.gz
gnu: Remove python2-natsort.
This package currently fails to build and has no users in Guix.

* gnu/packages/python-xyz.scm (python2-natsort): Remove variable.
(python-natsort)[properties]: Remove.
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 1 insertions, 17 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4cf7797f84..4e2e719afc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16045,23 +16045,7 @@ on a list such as @code{[@code{a20}, @code{a9}, @code{a1}, @code{a4},
 identifies numbers and sorts them separately from strings.  It can also sort
 version numbers, real numbers, mixed types and more, and comes with a shell
 command @command{natsort} that exposes this functionality in the command line.")
-    (license license:expat)
-    (properties `((python2-variant . ,(delay python2-natsort))))))
-
-;; Natsort 6.x are the last versions with support for Python 2.
-(define-public python2-natsort
-  (let ((base (package-with-python2 (strip-python2-variant python-natsort))))
-    (package (inherit base)
-             (version "6.2.1")
-             (source (origin
-                       (method url-fetch)
-                       (uri (pypi-uri "natsort" version))
-                       (sha256
-                        (base32
-                         "1mc9hbh6fv76xyz13frm7dgi05cf74f9j5wvcyjiy5234gylz565"))))
-             (native-inputs
-              `(("python2-pathlib" ,python2-pathlib)
-                ,@(package-native-inputs base))))))
+    (license license:expat)))
 
 (define-public glances
   (package