summary refs log tree commit diff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-04-05 22:27:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-04-10 18:33:12 +0200
commitcf637690aa8c0301875ce0623e858eadb2d9996d (patch)
tree0a27844a7d87a7c4af47a27b4fe52a2c8e95e882
parent757f2c1effe7d51d497f83c9d22bf8de066d8555 (diff)
downloadguix-cf637690aa8c0301875ce0623e858eadb2d9996d.tar.gz
gnu: emacs-ace-window: Update to 0.10.0
[[PGP Signed Part:No public key for 7C7AFFBEFEF2CB25 created at 2020-04-05T22:27:27+0200 using RSA]]
* gnu/packages/emacs-xyz.scm (emacs-ace-window) Update to 0.10.0.

From c3dc065f9247c98ba90fbf3ec9c51abb06417269 Mon Sep 17 00:00:00 2001
From: Michael Rohleder <mike@rohleder.de>
Date: Sun, 5 Apr 2020 22:15:50 +0200
Subject: [PATCH] gnu: emacs-ace-window: Update to 0.10.0

* gnu/packages/emacs-xyz.scm (emacs-ace-window) Update to 0.10.0.
-rw-r--r--gnu/packages/emacs-xyz.scm45
1 files changed, 21 insertions, 24 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b4c2760404..e700920266 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5976,33 +5976,30 @@ windows.")
     (license license:gpl3+)))
 
 (define-public emacs-ace-window
-  ;; last release version is from 2015
-  (let ((commit "a5344925e399e1f015721cda6cf5db03c90ab87a")
-        (revision "1"))
-    (package
-      (name "emacs-ace-window")
-      (version (git-version "0.9.0" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/abo-abo/ace-window.git")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "18jm8gfgnf6ja9aarws5650lw2zfi3wdwc5j8r5ijn5fcqhfy7rc"))))
-      (build-system emacs-build-system)
-      (propagated-inputs
-       `(("emacs-avy" ,emacs-avy)))
-      (home-page "https://github.com/abo-abo/ace-window")
-      (synopsis "Quickly switch windows in Emacs")
-      (description
-       "@code{ace-window} is meant to replace @code{other-window}.
+  (package
+    (name "emacs-ace-window")
+    (version "0.10.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/abo-abo/ace-window.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0f3r40d5yxp2pm2j0nn86s29nqj8py0jxjbj50v4ci3hsd92d8jl"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-avy" ,emacs-avy)))
+    (home-page "https://github.com/abo-abo/ace-window")
+    (synopsis "Quickly switch windows in Emacs")
+    (description
+     "@code{ace-window} is meant to replace @code{other-window}.
 In fact, when there are only two windows present, @code{other-window} is
 called.  If there are more, each window will have its first character
 highlighted.  Pressing that character will switch to that window.")
-      (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-iedit
   ;; Last release version was in 2016.