summary refs log tree commit diff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-01-11 14:44:02 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:53:44 -0500
commitcfe2cf2a29dd0ea392c44aded33bc9d3c01a3d76 (patch)
tree76f8d664152d387b2efd1926917b3f4be40f2ef4
parent355d87a0a562bb84b416163d4804919c497732b5 (diff)
downloadguix-cfe2cf2a29dd0ea392c44aded33bc9d3c01a3d76.tar.gz
gnu: python-pyfakefs: Disable unreliable test
* gnu/packages/check.scm (python-pyfakefs) [arguments]: Add new phase to
skip single test.
-rw-r--r--gnu/packages/check.scm12
1 files changed, 10 insertions, 2 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index ce00927c53..41571d1875 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -2756,13 +2756,21 @@ grew out of the @dfn{Vc} project.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
+         (add-after 'unpack 'patch-testsuite
+           (lambda _
+             ;; Time difference is larger than expected.
+             (substitute* "pyfakefs/tests/fake_filesystem_unittest_test.py"
+               (("(\\s+)def test_copy_real_file" all indent)
+                (string-append
+                  indent
+                  "@unittest.skip('disabled by guix')\n"
+                  all)))))
          ;; The default test suite does not run these extra tests.
          (add-after 'check 'check-pytest-plugin
            (lambda _
              (invoke
               "python" "-m" "pytest"
-              "pyfakefs/pytest_tests/pytest_plugin_test.py")
-             #t)))))
+              "pyfakefs/pytest_tests/pytest_plugin_test.py"))))))
     (native-inputs
      `(("python-pytest" ,python-pytest)))
     (build-system python-build-system)