summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2022-04-11 15:05:32 +0200
committerLudovic Courtès <ludo@gnu.org>2022-04-11 15:49:33 +0200
commitd81d8b1258af44636857795bab392135f5046e25 (patch)
tree8e028d9693ae3f5e8e72aea2f9a744d373e9c677
parent37fa61364ea815a5d15f2a929860fa6fe2219fc8 (diff)
downloadguix-d81d8b1258af44636857795bab392135f5046e25.tar.gz
gnu: hwloc: Remove input labels.
* gnu/packages/mpi.scm (hwloc-1)[inputs]: Remove labels.
(hwloc-2)[inputs]: Use 'modify-inputs'.
-rw-r--r--gnu/packages/mpi.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 946c55c4a5..5ffe0e6da2 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -79,15 +79,12 @@
                "doc"           ;400+ section 3 man pages
                "debug"))
     (inputs
-     `(("libx11" ,libx11)
-       ("cairo" ,cairo)
-       ("ncurses" ,ncurses)
-       ("expat" ,expat)
-       ,@(if (not (string-prefix? "armhf"
-                                  (or (%current-target-system)
-                                      (%current-system))))
-             `(("numactl" ,numactl))
-             '())))
+     (append (list libx11 cairo ncurses expat)
+             (if (not (string-prefix? "armhf"
+                                      (or (%current-target-system)
+                                          (%current-system))))
+                 (list numactl)
+                 '())))
     (propagated-inputs
      ;; hwloc.pc lists it in 'Requires.private'.
      (list libpciaccess))
@@ -163,7 +160,8 @@ bind processes, and much more.")
                 "13ajxwshxl1pa8b5gnkmm7hcg97m6xrlgz8vj1hmsb57qcv1skhd"))))
 
     ;; libnuma is no longer needed.
-    (inputs (alist-delete "numactl" (package-inputs hwloc-1)))
+    (inputs (modify-inputs (package-inputs hwloc-1)
+              (delete "numactl")))
     (arguments
      (substitute-keyword-arguments (package-arguments hwloc-1)
        ((#:phases phases)