summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-20 14:48:48 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-08-20 18:33:51 +0200
commite1ffd78270881e0c5b3f12a60a0caa75300557e7 (patch)
tree964a94c1223105cbca020e54349a24ce527988a3
parent8717b34cd42548f6071acfb2f9ed0491b8cc63e1 (diff)
downloadguix-e1ffd78270881e0c5b3f12a60a0caa75300557e7.tar.gz
gnu: dedukti: Fix reference to output.
* gnu/packages/ocaml.scm
  (dedukti)[arguments]<#:phases>: Use #$output.  Remove trailing #t.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/ocaml.scm39
1 files changed, 17 insertions, 22 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e89c1adbb9..82ee34c542 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4137,28 +4137,23 @@ cross-platform SDL C library.")
     (build-system ocaml-build-system)
     (arguments
      `(#:phases
-       (modify-phases %standard-phases
-         (delete 'configure)
-         (replace 'build
-           (lambda _
-             (invoke "make")
-             #t))
-         (replace 'check
-           (lambda _
-             (invoke "make" "tests")
-             #t))
-         (add-before 'install 'set-binpath
-           ;; Change binary path in the makefile
-           (lambda _
-             (let ((out (assoc-ref %outputs "out")))
-               (substitute* "GNUmakefile"
-                 (("BINDIR = (.*)$")
-                  (string-append "BINDIR = " out "/bin"))))
-             #t))
-         (replace 'install
-           (lambda _
-             (invoke "make" "install")
-             #t)))))
+       ,#~(modify-phases %standard-phases
+            (delete 'configure)
+            (replace 'build
+              (lambda _
+                (invoke "make")))
+            (replace 'check
+              (lambda _
+                (invoke "make" "tests")))
+            (add-before 'install 'set-binpath
+              ;; Change binary path in the makefile
+              (lambda _
+                (substitute* "GNUmakefile"
+                  (("BINDIR = (.*)$")
+                   (string-append "BINDIR = " #$output "/bin")))))
+            (replace 'install
+              (lambda _
+                (invoke "make" "install"))))))
     (synopsis "Proof-checker for the λΠ-calculus modulo theory, an extension of
 the λ-calculus")
     (description "Dedukti is a proof-checker for the λΠ-calculus modulo