summary refs log tree commit diff
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2017-04-05 14:38:51 +0200
committerLeo Famulari <leo@famulari.name>2017-04-07 10:01:54 -0400
commitf214d470d7277370db03825c6cd35a9a5ee40732 (patch)
treeec9ff61e81ec84ac3c852d55aaf9af2b5a50ffe9
parent6cfb860a7ae623f03f14dc3b6b2bed61b84558b4 (diff)
downloadguix-f214d470d7277370db03825c6cd35a9a5ee40732.tar.gz
gnu: ratpoison: Update to 1.4.9.
* gnu/packages/ratpoison.scm (ratpoison): Update to 1.4.9.
[inputs]: Remove libxinerama. Add libxrandr.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/ratpoison.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/ratpoison.scm b/gnu/packages/ratpoison.scm
index 23adf859a7..e68b345b06 100644
--- a/gnu/packages/ratpoison.scm
+++ b/gnu/packages/ratpoison.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
+;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -43,14 +44,14 @@
 (define-public ratpoison
   (package
     (name "ratpoison")
-    (version "1.4.8")
+    (version "1.4.9")
     (source
      (origin (method url-fetch)
              (uri (string-append "mirror://savannah/ratpoison/ratpoison-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "1w502z55vv7zs45l80nsllqh9fvfwjfdfi11xy1qikhzdmirains"))
+               "1wfir1gvh5h7izgvx2kd1pr2k7wlncd33zq7qi9s9k2y0aza93yr"))
              (patches (search-patches "ratpoison-shell.patch"))))
     (build-system gnu-build-system)
     (arguments
@@ -70,7 +71,7 @@
        ("freetype" ,freetype)
        ("libXft" ,libxft)
        ("libXi" ,libxi)
-       ("libxinerama" ,libxinerama)
+       ("libxrandr" ,libxrandr)
        ("libXpm" ,libxpm)
        ("libXt" ,libxt)
        ("libXtst" ,libxtst)