summary refs log tree commit diff
diff options
context:
space:
mode:
authorRyan Desfosses <rdes@protonmail.com>2020-12-07 18:17:52 -0500
committerOleg Pykhalov <go.wigust@gmail.com>2020-12-08 07:59:22 +0300
commitfedf7d57210b4a65dac6366b0897f1d69dc40423 (patch)
treec90281ca81bce1ec42862e71d403dfe817bca67e
parent403dda2e66dc5c8f23bf66086815133546df1ba0 (diff)
downloadguix-fedf7d57210b4a65dac6366b0897f1d69dc40423.tar.gz
gnu: Add emacs-map.
* gnu/packages/emacs-xyz.scm (emacs-map): New variable.

Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
-rw-r--r--gnu/packages/emacs-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 28f3695df8..5ee7ad906d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25723,3 +25723,23 @@ syntax highlighting and UI components.")
        "This Emacs package provides a Janet REPL to evaluate @code{janet-mode}
 s-expression.")
       (license license:expat))))
+
+(define-public emacs-map
+  (package
+    (name "emacs-map")
+    (version "2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://elpa.gnu.org/packages/map-"
+                           version ".el"))
+       (sha256
+        (base32
+         "0ydz5w1n4vwhhzxxj003s7jv8n1wjijwfryk5z93bwhnr0cak0i0"))))
+    (build-system emacs-build-system)
+    (home-page "http://elpa.gnu.org/packages/map.html")
+    (synopsis "Map manipulation functions")
+    (description "This package provides Emacs map-manipulation functions that
+work on alists, hash-table and arrays.  All functions are prefixed with
+@code{map-}.")
+    (license license:gpl3+)))