summary refs log tree commit diff
diff options
context:
space:
mode:
authorStephen Scheck <sscheck@gmail.com>2019-12-26 14:53:46 -0600
committerLudovic Courtès <ludo@gnu.org>2019-12-30 23:18:16 +0100
commit0e9c253313da7bdd72a6e712c75e366714ef23ff (patch)
tree7f85b1db8a64fbeec7b87e56340e57a6c5e79ca5
parent5f1553ce9ea15584c66d0aa4688e036313d2f0ab (diff)
downloadguix-0e9c253313da7bdd72a6e712c75e366714ef23ff.tar.gz
gnu: Add perl-net-bgp.
* gnu/packages/perl.scm (perl-net-bgp): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/perl.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index f732c0ed46..44b764618b 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -22,6 +22,7 @@
 ;;; Copyright © 2018, 2019 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2018 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2019 Stephen J. Scheck <sscheck@cpan.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6697,6 +6698,31 @@ cycle.  Functions called in the package itself will still be bound by their
 name, but they won't show up as methods on your class or instances.")
     (license (package-license perl))))
 
+(define-public perl-net-bgp
+  (package
+    (name "perl-net-bgp")
+    (version "0.17")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "mirror://cpan/authors/id/S/SS/SSCHECK/Net-BGP-" version ".tar.gz"))
+        (sha256 (base32 "0za8x9cn5n2hasb14p7dr537lggvrcsl23pgldxf5y03wmk6h35y"))))
+    (build-system perl-build-system)
+    (home-page "https://metacpan.org/release/Net-BGP")
+    (synopsis "Object-oriented API to the BGP protocol")
+    (description
+      "This module is an implementation of the BGP-4 inter-domain routing protocol.
+It encapsulates all of the functionality needed to establish and maintain a
+BGP peering session and exchange routing update information with the peer.
+It aims to provide a simple API to the BGP protocol for the purposes of
+automation, logging, monitoring, testing, and similar tasks using the
+power and flexibility of perl.  The module does not implement the
+functionality of a RIB (Routing Information Base) nor does it modify the
+kernel routing table of the host system.  However, such operations could be
+implemented using the API provided by the module.")
+  (license perl-license)))
+
 (define-public perl-net-dns-native
   (package
     (name "perl-net-dns-native")