summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2015-05-27 21:37:06 -0400
committerDavid Thompson <davet@gnu.org>2015-05-29 20:05:57 -0400
commit2cbc105bb358ca473e35395b57b5af2c54110567 (patch)
treed5740d23a4983273d9b998702d02951ff3c22639
parentd4fde1f23914457ba01ae476bdff73dccbe38a34 (diff)
downloadguix-2cbc105bb358ca473e35395b57b5af2c54110567.tar.gz
gnu: Add bundler.
* gnu/packages/ruby.scm (bundler): New variable.
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a738d3c471..3d23e74bfa 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -316,3 +316,26 @@ Ruby.  This meta-package includes the RSpec test runner, along with the
 expectations and mocks frameworks.")
     (home-page "http://rspec.info/")
     (license license:expat)))
+
+;; Bundler is yet another source of circular dependencies, so we must disable
+;; its test suite as well.
+(define-public bundler
+  (package
+    (name "bundler")
+    (version "1.9.9")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/bundler/bundler/archive/v"
+                                  version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "08flx3n9hb3yz8mm5k16cdz0sb7g774f6vxn6gc3wfh5la83vfyx"))))
+    (build-system ruby-build-system)
+    (arguments
+     '(#:tests? #f)) ; avoid dependency cycles
+    (synopsis "Ruby gem bundler")
+    (description "Bundler automatically downloads and installs a list of gems
+specified in a \"Gemfile\", as well as their dependencies.")
+    (home-page "http://bundler.io/")
+    (license license:expat)))