summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-10-23 10:00:38 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-10-23 10:43:58 +0300
commit3f03cb20d6525d85578912f2894b9559ef53bff9 (patch)
treeb1f5d8445523cb05d8c442d9e4a029e2c0b01b65
parent847172e44f501a0537a682473c2fa8727b10879d (diff)
downloadguix-3f03cb20d6525d85578912f2894b9559ef53bff9.tar.gz
gnu: Add rust-redox-syscall-0.1.
* gnu/packages/rust-cbindgen.scm (rust-redox-syscall-0.1): New hidden
variable.
-rw-r--r--gnu/packages/rust-cbindgen.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/rust-cbindgen.scm b/gnu/packages/rust-cbindgen.scm
index 3ffa3f6d48..012b977b36 100644
--- a/gnu/packages/rust-cbindgen.scm
+++ b/gnu/packages/rust-cbindgen.scm
@@ -546,3 +546,23 @@ functionality.")
 @code{rdrand} and @cpde{rdseed} instructions")
     (properties '((hidden? . #t)))
     (license license:isc)))
+
+(define rust-redox-syscall-0.1
+  (package
+    (name "rust-redox-syscall")
+    (version "0.1.56")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "redox_syscall" version))
+        (file-name (string-append name "-" version ".crate"))
+        (sha256
+         (base32
+          "110y7dyfm2vci4x5vk7gr0q551dvp31npl99fnsx2fb17wzwcf94"))))
+    (build-system cargo-build-system)
+    (home-page "https://gitlab.redox-os.org/redox-os/syscall")
+    (synopsis "Rust library to access raw Redox system calls")
+    (description "This package provides a Rust library to access raw Redox
+system calls.")
+    (properties '((hidden? . #t)))
+    (license license:expat)))