summary refs log tree commit diff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:10:15 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:59 -0400
commit475d3668660945f992886f8e16809255659eb271 (patch)
treef87bb86e92f3548eda8350f47a6b97e7e5262fe2
parent8ea94489fd954960acb2edc269b7cb88a3a38bae (diff)
downloadguix-475d3668660945f992886f8e16809255659eb271.tar.gz
gnu: Add ghc-chell-quickcheck-bootstrap.
* gnu/packages/haskell.scm (ghc-chell-quickcheck-bootstrap): New variable.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 39a231266d..ee502c97fe 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -7279,4 +7279,29 @@ libraries such as @code{chell-quickcheck} to support more complex
 testing strategies.")
     (license license:expat)))
 
+(define ghc-chell-quickcheck-bootstrap
+  (package
+    (name "ghc-chell-quickcheck-bootstrap")
+    (version "0.2.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/chell-quickcheck/chell-quickcheck-"
+             version ".tar.gz"))
+       (sha256
+        (base32
+         "02bkcnx5k6r5csdnnkvk4wfd0l36nxb87i1463ynw17n7ym9s4cs"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-chell" ,ghc-chell)
+       ("ghc-random" ,ghc-random)
+       ("ghc-quickcheck" ,ghc-quickcheck)))
+    (arguments
+     `(#:tests? #f))
+    (home-page "https://john-millikin.com/software/chell/")
+    (synopsis "QuickCheck support for the Chell testing library")
+    (description "More complex tests for @code{chell}.")
+    (license license:expat)))
+
 ;;; haskell.scm ends here