summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-08 13:05:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-08 17:57:24 +0300
commit495df0b0c600c70c44903efb6a08cf007f0d8ee8 (patch)
tree1f6604feb6faf8997798d5d66769a5cfbd7d74e6
parent2e317bbfde5a651feeaff7e3aedbb847062c0e40 (diff)
downloadguix-495df0b0c600c70c44903efb6a08cf007f0d8ee8.tar.gz
gnu: Add julia-colorvectorspace.
* gnu/packages/julia-xyz.scm (julia-colorvectorspace): New variable.
-rw-r--r--gnu/packages/julia-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 41a7b25ac4..0718463b33 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -379,6 +379,34 @@ constructors, and sets up traits and show methods to make them easier to work
 with.")
     (license license:expat)))
 
+(define-public julia-colorvectorspace
+  (package
+    (name "julia-colorvectorspace")
+    (version "0.9.5")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaGraphics/ColorVectorSpace.jl")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "1gx4k1bvf6lkzxphnvpkw857ihrkifhb68yvsj889k9pf1vda3fq"))))
+    (build-system julia-build-system)
+    (propagated-inputs
+     `(("julia-colortypes" ,julia-colortypes)
+       ("julia-specialfunctions" ,julia-specialfunctions)
+       ("julia-tensorcore" ,julia-tensorcore)))
+    (native-inputs
+     `(("julia-colors" ,julia-colors)))
+    (home-page "https://github.com/JuliaGraphics/ColorVectorSpace.jl")
+    (synopsis "Treat colors as n-vectors for the purposes of arithmetic")
+    (description "This package is an add-on to @code{ColorTypes.jl} and provides
+fast mathematical operations for objects with types such as RGB and Gray.
+Specifically, with this package both grayscale and RGB colors are treated as if
+they are points in a normed vector space.")
+    (license license:expat)))
+
 (define-public julia-commonsubexpressions
   (package
     (name "julia-commonsubexpressions")