summary refs log tree commit diff
diff options
context:
space:
mode:
authorWinterHound <winterhound@yandex.com>2021-04-20 23:53:45 +0530
committerLudovic Courtès <ludo@gnu.org>2021-05-22 23:50:11 +0200
commit58b85f7f419e77930765647ffc41011c1103066e (patch)
tree5ab3e74395ba83a44f0189fe52c86d0d33f9cc27
parentc8d6fa77478acdd2ed7640b0f1011819b3e5d5b5 (diff)
downloadguix-58b85f7f419e77930765647ffc41011c1103066e.tar.gz
gnu: Add xdo.
* gnu/packages/xdisorg.scm (xdo): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/xdisorg.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 6d7794ef43..bf4b062973 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -511,6 +511,39 @@ manager supports it, you can use xdotool to switch desktops, move windows
 between desktops, and change the number of desktops.")
     (license license:bsd-3)))
 
+(define-public xdo
+  (package
+    (name "xdo")
+    (version "0.5.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/baskerville/xdo")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1h3jrygcjjbavdbkpx2hscsf0yf97gk487lzjdlvymd7dxdv9hy9"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f                      ; no tests
+       #:make-flags
+       (list (string-append "CC=" ,(cc-for-target))
+             (string-append "PREFIX=" %output))
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))
+    (inputs
+     `(("libxcb" ,libxcb)
+       ("xcb-util-wm" ,xcb-util-wm)
+       ("xcb-util" ,xcb-util)))
+    (home-page "https://github.com/baskerville/xdo")
+    (synopsis "Small X utility to perform elementary actions on windows")
+    (description
+     "Apply the given action to the given windows.  If no window IDs and no
+options are given, the action applies to the focused window.")
+    (license license:bsd-2)))
+
 (define-public xeyes
   (package
     (name "xeyes")