summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-06 17:25:02 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-07 15:06:22 +0100
commit5de561a79634e0814ea22f1cfece9a09efa120be (patch)
treed591fbe5d2972d0556d8fcfb3918a74ae34a219f
parent4c8413cd617e56891939ac50c48a620c606ef145 (diff)
downloadguix-5de561a79634e0814ea22f1cfece9a09efa120be.tar.gz
gnu: gnome-todo: Fix compatibility with libical >= 3.0.
* gnu/packages/patches/gnome-todo-libical-compat.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/gnome.scm (gnome-todo)[source](patches): Use it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm1
-rw-r--r--gnu/packages/patches/gnome-todo-libical-compat.patch17
3 files changed, 19 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index ea9c5da0cc..6c64068528 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -724,6 +724,7 @@ dist_patch_DATA =						\
   %D%/packages/patches/glog-gcc-5-demangling.patch		\
   %D%/packages/patches/gmp-arm-asm-nothumb.patch		\
   %D%/packages/patches/gmp-faulty-test.patch			\
+  %D%/packages/patches/gnome-todo-libical-compat.patch		\
   %D%/packages/patches/gnome-tweak-tool-search-paths.patch	\
   %D%/packages/patches/gnucash-price-quotes-perl.patch		\
   %D%/packages/patches/gnutls-skip-trust-store-test.patch	\
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index de66705b05..516a590dc4 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6207,6 +6207,7 @@ desktop.  It supports multiple calendars, month, week and year view.")
               (uri (string-append "mirror://gnome/sources/" name "/"
                                   (version-major+minor version) "/"
                                   name "-" version ".tar.xz"))
+              (patches (search-patches "gnome-todo-libical-compat.patch"))
               (sha256
                (base32
                 "106xx1w18pxjmj5k0k2qjzi6b3c3kaz7b5kyrpknykibnr401ff9"))))
diff --git a/gnu/packages/patches/gnome-todo-libical-compat.patch b/gnu/packages/patches/gnome-todo-libical-compat.patch
new file mode 100644
index 0000000000..34f2e254b2
--- /dev/null
+++ b/gnu/packages/patches/gnome-todo-libical-compat.patch
@@ -0,0 +1,17 @@
+Fix compatibility with libical 3.0.
+
+Patch copied from Arch Linux:
+https://git.archlinux.org/svntogit/packages.git/tree/trunk/gnome-todo-3.26.2-libical-3.0.patch?h=packages/gnome-todo
+
+diff -up gnome-todo-3.26.2/src/gtd-task.c.libical-3.0 gnome-todo-3.26.2/src/gtd-task.c
+--- gnome-todo-3.26.2/src/gtd-task.c.libical-3.0	2017-11-08 14:53:53.484294926 +0100
++++ gnome-todo-3.26.2/src/gtd-task.c	2017-11-08 14:53:57.208294874 +0100
+@@ -778,7 +778,7 @@ gtd_task_set_complete (GtdTask  *task,
+           dt->minute = g_date_time_get_minute (now);
+           dt->second = g_date_time_get_seconds (now);
+           dt->is_date = 0;
+-          dt->is_utc = 1;
++          dt->zone = icaltimezone_get_utc_timezone ();
+ 
+           /* convert timezone
+            *