summary refs log tree commit diff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-07-19 03:51:53 +0000
committerLudovic Courtès <ludo@gnu.org>2021-07-19 19:57:51 +0200
commit5e437ce812b4a46e513368e0b76d8c158b323555 (patch)
treeddc19b0dd4d9665d9b499bdc1c789d9252ff52b3
parent3436d3f801170b04bf8f7e3fef337248c7a778bc (diff)
downloadguix-5e437ce812b4a46e513368e0b76d8c158b323555.tar.gz
gnu: Add emacs-jupyter.
* gnu/packages/emacs-xyz.scm (emacs-jupyter): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 01f39e6a9d..5fe1c20976 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16003,6 +16003,34 @@ Features:
 the pipeline, featuring the support for running @code{emacsclient}.")
     (license license:gpl3+)))
 
+(define-public emacs-jupyter
+  (package
+    (name "emacs-jupyter")
+    (version "0.8.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/nnicandro/emacs-jupyter")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1sr007wsl2y6wqpzkmv3inbpwhvgdcb2nmqzgfg7w1awapi2r13p"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-company" ,emacs-company) ;optional
+       ("emacs-markdown-mode" ,emacs-markdown-mode) ;optional
+       ("emacs-simple-httpd" ,emacs-simple-httpd)
+       ("emacs-websocket" ,emacs-websocket)
+       ("emacs-zmq" ,emacs-zmq)))
+    (home-page "https://github.com/nnicandro/emacs-jupyter")
+    (synopsis "Emacs interface to communicate with Jupyter kernels")
+    (description "This package provides an Emacs interface to communicate with
+Jupyter kernels.  It provides REPL and @code{org-mode} source code block
+frontends to Jupyter kernels and kernel interactions integrated with Emacs'
+built-in features.")
+    (license license:gpl3+)))
+
 (define-public emacs-hcl-mode
   (package
     (name "emacs-hcl-mode")