summary refs log tree commit diff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-03-27 17:59:16 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-04-08 17:31:12 +0200
commit61c02099a3216a563db9401172f776a0a0d18bde (patch)
tree611464ad38739ec780b27f8efca9c3229699ce54
parenteaa3088e2c689087d41abe9ce450d4f967b57b5f (diff)
downloadguix-61c02099a3216a563db9401172f776a0a0d18bde.tar.gz
gnu: Add ghc-containers.
* gnu/packages/haskell.scm (ghc-containers): New variable.
-rw-r--r--gnu/packages/haskell.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0ae6d921af..c3f9e57595 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -602,4 +602,34 @@ of constructor applications, instances of this class for primitive
 types, and a variety of traversals.")
     (license bsd-3)))
 
+(define-public ghc-containers
+  (package
+    (name "ghc-containers")
+    (version "0.5.6.3")
+    (outputs '("out" "doc"))
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "http://hackage.haskell.org/package/containers/containers-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1kcd55nl0vzi99i8sr8fmc5j25fv7m0a9hd3nihnq1pd64pfciqn"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-hunit" ,ghc-hunit)
+       ("ghc-quickcheck" ,ghc-quickcheck)))
+    (arguments
+     `(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
+    (home-page "http://hackage.haskell.org/package/containers")
+    (synopsis "Assorted concrete container types")
+    (description
+     "This package contains efficient general-purpose implementations of
+various basic immutable container types.  The declared cost of each operation
+is either worst-case or amortized, but remains valid even if structures are
+shared.")
+    (license bsd-3)))
+
 ;;; haskell.scm ends here