summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-07-31 03:36:37 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-10-19 00:16:51 +0200
commit6bb9645e57b8561598cc1d8337a50710e28b0267 (patch)
tree28b0328407b82da0f0626419fecdae3f77b2348c
parenta0fd9a3ca9df2ea7d68c7e3e18cea16eac0fa48b (diff)
downloadguix-6bb9645e57b8561598cc1d8337a50710e28b0267.tar.gz
gnu: Add python2-funcsigs.
* gnu/packages/python.scm (python2-funcsigs): New variable.
-rw-r--r--gnu/packages/python.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 2023e8cc03..3e0d4faf14 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1845,6 +1845,27 @@ interfaces and processes.")
 (define-public python2-nose2
   (package-with-python2 python-nose2))
 
+(define-public python2-funcsigs
+  (package
+    (name "python2-funcsigs")
+    (version "1.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "funcsigs" version))
+              (sha256
+               (base32
+                "0l4g5818ffyfmfs1a924811azhjj8ax9xd1cffr1mzd3ycn0zfx7"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:python ,python-2))
+    (native-inputs
+     `(("python2-unittest2" ,python2-unittest2)))
+    (home-page "http://funcsigs.readthedocs.org")
+    (synopsis "Python function signatures from PEP362")
+    (description
+     "Backport of @code{funcsigs} which was introduced in Python 3.3.")
+    (license license:asl2.0)))
+
 (define-public python-unittest2
   (package
     (name "python-unittest2")