summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-03 00:50:20 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-05 17:59:03 +0100
commit7a039449aa0e9d523df5e69d84c0ea257ef911dd (patch)
tree1eedbf72528aec0d194312c327242f7421785a50
parentbadcb119c57fe1a6fc617d2f4a237c1192305584 (diff)
downloadguix-7a039449aa0e9d523df5e69d84c0ea257ef911dd.tar.gz
gnu: python-fonttools: Update to 4.2.0.
* gnu/packages/python-xyz.scm (python-fonttools): Update to 4.2.0.
(python2-fonttools): Stay on 3.38.0.
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9dd97a61bd..01bb565027 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6803,13 +6803,13 @@ add functionality and customization to your projects with their own plugins.")
 (define-public python-fonttools
   (package
     (name "python-fonttools")
-    (version "3.38.0")
+    (version "4.2.0")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "fonttools" version ".zip"))
               (sha256
                (base32
-                "12ripk3s7skgxr1bs9r8n13r94ym3s8iir7ivfixls9fa4dabmlh"))))
+                "0psy6z52jn49wp93s3k7kj0jzji1cad3wnwgm6c26vphv5appk4v"))))
     (build-system python-build-system)
     (native-inputs
      `(("unzip" ,unzip)
@@ -6825,8 +6825,18 @@ also contains a tool called “TTX” which converts TrueType/OpenType fonts to
 from an XML-based format.")
     (license license:expat)))
 
+;; Fonttools 4.x dropped support for Python 2, so stick with 3.x here.
 (define-public python2-fonttools
-  (package-with-python2 python-fonttools))
+  (let ((base (package-with-python2 (strip-python2-variant python-fonttools))))
+    (package/inherit
+     base
+     (version "3.38.0")
+     (source (origin
+               (method url-fetch)
+               (uri (pypi-uri "fonttools" version ".zip"))
+               (sha256
+                (base32
+                 "12ripk3s7skgxr1bs9r8n13r94ym3s8iir7ivfixls9fa4dabmlh")))))))
 
 (define-public python-ly
   (package