summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-03 11:21:00 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:12 -0500
commit853748c424d391714a249a2eada6bad12d19455a (patch)
tree9c0fb7576a04e1e2d5820102ce6d134a5c9a7c9a
parent7d30fcf38752b7cabf76579b7600aeb61dc65915 (diff)
downloadguix-853748c424d391714a249a2eada6bad12d19455a.tar.gz
gnu: ghc-bytestring-handle: Fix Cabal dependency constraints.
Rather than patch the 'base' constraints, we update the Cabal file to r1
so that it accepts 'base' from GHC 8.6.

* gnu/packages/haskell-xyz.scm (ghc-bytestring-handle): Update the Cabal
file to r1; remove 'base' constraint fix; and update the 'QuickCheck'
constraint to allow version 2.13.
-rw-r--r--gnu/packages/haskell-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index f1764a3f18..c86deae8f7 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -1046,15 +1046,15 @@ Compatibility package for older packages.")
          "18f17aja1ivhr3zyg2cccn2m03hdn5jf5410dndkhf12gvgiqs7y"))))
     (build-system haskell-build-system)
     (arguments
-     `(#:phases
+     `(#:cabal-revision
+       ("1" "0x11aj6w1lijh84jcdq1qgyvdnc7i9ivbyq4wf9rxicg57viisz9")
+       #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'update-constraints
            (lambda _
              (substitute* "bytestring-handle.cabal"
                (("QuickCheck >= 2\\.1\\.2 && < 2\\.11")
-                "QuickCheck >= 2.1.2 && < 2.12")
-               (("base >= 4\\.2 && < 4\\.11")
-                "base >= 4.2 && < 4.12")))))))
+                "QuickCheck >= 2.1.2 && < 2.14")))))))
     (inputs
      `(("ghc-hunit" ,ghc-hunit)
        ("ghc-quickcheck" ,ghc-quickcheck)