summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 16:38:43 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-13 22:41:37 +0100
commit8fed766a7d3988ec39861c546507b945da9c84d9 (patch)
tree3f84b82fb728be2b22b3b2b66b666bd2687191af
parent595d9502238947e276eb49c63b74b519537a81d5 (diff)
downloadguix-8fed766a7d3988ec39861c546507b945da9c84d9.tar.gz
gnu: Add r-abc-rap.
* gnu/packages/cran.scm (r-abc-rap): New variable.
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d06d1d2d5d..8916e50f10 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16229,3 +16229,24 @@ and understanding in statistics.  The current version includes properties of
 normal distribution, properties of sampling distribution, one-sample z and t
 tests, two samples independent (unpaired) t test and analysis of variance.")
     (license license:gpl3)))
+
+(define-public r-abc-rap
+  (package
+    (name "r-abc-rap")
+    (version "0.9.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "ABC.RAP" version))
+       (sha256
+        (base32
+         "1kdspln17v0krvahcd55vib4dv5azp60b3r1zf489x10qqbp1mxk"))))
+    (properties `((upstream-name . "ABC.RAP")))
+    (build-system r-build-system)
+    (home-page "https://cran.r-project.org/web/packages/ABC.RAP/")
+    (synopsis "Array-based CpG region analysis pipeline")
+    (description
+     "This package aims to identify candidate genes that are differentially
+methylated between cases and controls.  It applies Student's t-test and delta
+beta analysis to identify candidate genes containing multiple CpG sites.")
+    (license license:gpl3)))