summary refs log tree commit diff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2018-10-27 18:49:29 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-27 18:54:39 +0200
commitb509df82de369262403acf2e74f1e80fdc02c96d (patch)
tree7972c65825802fbf79b970c6e1d1cfe14b21718c
parentb5a310056cf942a5675bf3c862ece273c28a4ba4 (diff)
downloadguix-b509df82de369262403acf2e74f1e80fdc02c96d.tar.gz
gnu: Add r-abundant.
* gnu/packages/cran.scm (r-abundant): New variable.

Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3cf1e09df1..7f2123b90e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6185,6 +6185,29 @@ estimation problem.")
     ;; The CRAN page only says GPL-3.
     (license license:gpl3+)))
 
+(define-public r-abundant
+  (package
+    (name "r-abundant")
+    (version "1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "abundant" version))
+       (sha256
+        (base32 "1m76qdmqvwpgm0sihazi2dna7cgsz9rljal18vgffb5wamwmg9k7"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-quic" ,r-quic)))
+    (home-page "https://cran.r-project.org/web/packages/abundant/")
+    (synopsis "Abundant regression and high-dimensional principal fitted components")
+    (description
+     "This package provides tools to fit and predict with the high-dimensional
+principal fitted components model.  This model is described by Cook, Forzani,
+and Rothman (2012) @url{doi:10.1214/11-AOS962}.")
+    ;; The DESCRIPTION file states GPL-2, but since it directly depends on a
+    ;; GPLv3+ package (QUIC) this likely means GPLv2+.
+    (license license:gpl2+)))
+
 (define-public r-ac3net
   (package
     (name "r-ac3net")