summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-03 06:24:11 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-03 15:04:00 +0200
commitbcfec279af5086fec51a44ecf76cecedd4f73d44 (patch)
treed2e3a98c3c5a814a8662c949213fe9dc38eca312
parent7d00f2adde64db72e6a7f20d7a2fdc7d443d918c (diff)
downloadguix-bcfec279af5086fec51a44ecf76cecedd4f73d44.tar.gz
gnu: Add ghc-word-wrap.
* gnu/packages/haskell-xyz.scm (ghc-word-wrap): New public variable.
-rw-r--r--gnu/packages/haskell-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 1fa7310fab..087e60fc9a 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -15161,6 +15161,28 @@ modernized interface.")
      "A clone of wl-pprint for use with the text library.")
     (license license:bsd-3)))
 
+(define-public ghc-word-wrap
+  (package
+    (name "ghc-word-wrap")
+    (version "0.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "word-wrap/word-wrap-" version ".tar.gz"))
+       (sha256
+        (base32 "15rcqhg9vb7qisk9ryjnyhhfgigxksnkrczycaw2rin08wczjwpb"))))
+    (build-system haskell-build-system)
+    (native-inputs `(("ghc-hspec" ,ghc-hspec)))
+    (arguments
+     `(#:cabal-revision
+       ("1" "1k4w4g053vhmpp08542hrqaw81p3p35i567xgdarqmpghfrk68pp")))
+    (home-page "https://github.com/jtdaugherty/word-wrap/")
+    (synopsis "Haskell library for word-wrapping text")
+    (description
+     "The @code{word-wrap} Haskell library wraps long lines of text.")
+    (license license:bsd-3)))
+
 (define-public ghc-word8
   (package
     (name "ghc-word8")