summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-02 21:55:55 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-02 21:55:55 +0200
commitc8f2050ab6d192abee199fd0a37b1fdf2ab9c281 (patch)
treea6c55f659ee931973cc74987f825278ef65efc29
parent7ce9139f96b207a352c7e55f7ffe7dbd992b246a (diff)
downloadguix-c8f2050ab6d192abee199fd0a37b1fdf2ab9c281.tar.gz
gnu: gtkmm: Remove GCC5 workaround.
* gnu/packages/gtk.scm (gtkmm)[arguments]: Remove <#:configure-flags>.
* gnu/packages/gtk.scm (gtkmm-2)[arguments]: Likewise.
-rw-r--r--gnu/packages/gtk.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index e2e3b4365a..5098019506 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1115,10 +1115,7 @@ toolkit.")
        ("gtk+" ,gtk+)
        ("glibmm" ,glibmm)))
     (arguments
-     `(;; XXX: Tests require C++14 or later.  Remove this when the default
-       ;; compiler is >= GCC6.
-       #:configure-flags '("CXXFLAGS=-std=gnu++14")
-       #:disallowed-references (,xorg-server-for-tests)
+     `(#:disallowed-references (,xorg-server-for-tests)
        #:phases (modify-phases %standard-phases
                   (add-before 'check 'run-xvfb
                     (lambda* (#:key inputs #:allow-other-keys)
@@ -1154,8 +1151,7 @@ extensive documentation, including API reference and a tutorial.")
              (sha256
               (base32
                "0wkbzvsx4kgw16f6xjdc1dz7f77ldngdila4yi5lw2zrgcxsb006"))))
-    (arguments
-     '(#:configure-flags '("CPPFLAGS=-std=c++11"))) ; required by libsigc++
+    (arguments '())
     (native-inputs `(("pkg-config" ,pkg-config)))
     (propagated-inputs
      `(("pangomm" ,pangomm)