summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 23:05:18 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-14 13:35:54 +0100
commitcb350053dab549e9bbd85aec651e3662a9f68062 (patch)
treeef47c002e4c3a44786dc803ec09ccf7e0c605897
parent5d887a03551a24228a4cf5519bcd27a5ae6a123b (diff)
downloadguix-cb350053dab549e9bbd85aec651e3662a9f68062.tar.gz
gnu: Add r-tuner.
* gnu/packages/cran.scm (r-tuner): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6f2eb07951..b1217ad992 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -17373,3 +17373,27 @@ are used, contrary to higher dimensions when all derivatives are linearly
 approximated.  Several non-archimax families (normal, FGM, Plackett) are
 provided as well.")
     (license license:gpl2)))
+
+(define-public r-tuner
+  (package
+    (name "r-tuner")
+    (version "1.3.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "tuneR" version))
+       (sha256
+        (base32
+         "0av978m4h2iqazyfq6n2cgkh4wpllihh7s29lah2nb8ngc0w5hxx"))))
+    (properties `((upstream-name . "tuneR")))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-signal" ,r-signal)))
+    (home-page "https://cran.r-project.org/web/packages/tuneR/")
+    (synopsis "Analysis of music and speech")
+    (description
+     "This is a package for the analysis of music and speech.  Analyze music
+and speech, extract features like MFCCs, handle wave files and their
+representation in various ways, read MP3, read MIDI, perform steps of a
+transcription, ...")
+    ;; Either of these versions.
+    (license (list license:gpl2 license:gpl3))))