summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:29:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-21 11:29:33 +0300
commitcd760d221c7a04542ff8edada678b836992f68b8 (patch)
tree06d34e5993f9c5d8d2636113b510670f5583b58f
parent85fb79f1f668042f72227bff6a33c3c6bd3df187 (diff)
downloadguix-cd760d221c7a04542ff8edada678b836992f68b8.tar.gz
gnu: Add python-flufl-lock.
* gnu/packages/python-xyz.scm (python-flufl-lock): New variable.
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ef7a4f31c4..7361fa765e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20715,3 +20715,28 @@ file format of section, keys, and values.  The config file supports inheritance
 to minimize duplication of information across files.  The format supports schema
 validation.")
     (license license:lgpl3)))
+
+(define-public python-flufl-lock
+  (package
+    (name "python-flufl-lock")
+    (version "4.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "flufl.lock" version))
+        (sha256
+         (base32
+          "055941zyma3wfx25jhm8wcsghpv3jc3iwi1gdrdjhzcnfhn62lxq"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-atpublic" ,python-atpublic)
+       ("python-psutil" ,python-psutil)))
+    (home-page "https://flufllock.readthedocs.io")
+    (synopsis "NFS-safe file locking with timeouts for POSIX systems")
+    (description
+     "The @dfn{flufl.lock} package provides NFS-safe file locking with
+timeouts for POSIX systems.  It is similar to the @code{O_EXCL} option of the
+@code{open} system call but uses a lockfile.  Lock objects support lock-breaking
+and have a maximum lifetime built-in.")
+    (license (list license:asl2.0
+                   license:lgpl3))))    ; only for setup_helpers.py