summary refs log tree commit diff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 16:10:03 +0000
committerLeo Famulari <leo@famulari.name>2016-09-22 20:09:57 -0400
commitce242fd05eda0f0ffddb05f895358be0648881e7 (patch)
treeeb1ce1c09a75dc77d3b0aaa38eba52280cf989ae
parent6e0741f739fe08ad686b73c1cf90118a2d649905 (diff)
downloadguix-ce242fd05eda0f0ffddb05f895358be0648881e7.tar.gz
gnu: ghc-fgl: Update to 5.5.3.0.
* gnu/packages/haskell.scm (ghc-fgl): Update to 5.5.3.0.
[inputs]: Add ghc-hspec and ghc-quickcheck.

Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/haskell.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 523fceb31c..ae343a24d4 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3032,7 +3032,7 @@ variety of traversals.")
 (define-public ghc-fgl
   (package
     (name "ghc-fgl")
-    (version "5.5.1.0")
+    (version "5.5.3.0")
     (outputs '("out" "doc"))
     (source
      (origin
@@ -3043,9 +3043,12 @@ variety of traversals.")
              ".tar.gz"))
        (sha256
         (base32
-         "0rcmz0xlyr1wj490ffja29z1jgl51gz19ka609da6bx39bwx7nga"))))
+         "0fbyb6jxy9whgrv6dgnkzz70cmy98arx3q2gnkhgl4a3d7idh36p"))))
     (build-system haskell-build-system)
-    (inputs `(("ghc-mtl" ,ghc-mtl)))
+    (inputs
+     `(("ghc-mtl" ,ghc-mtl)
+       ("ghc-hspec" ,ghc-hspec)
+       ("ghc-quickcheck" ,ghc-quickcheck)))
     (home-page "http://web.engr.oregonstate.edu/~erwig/fgl/haskell")
     (synopsis
      "Martin Erwig's Functional Graph Library")