summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-13 12:57:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:45 +0200
commitda2b2d490bf2873065b5e65d471a50c662bd3234 (patch)
tree491c294b3b479de29384a4e0ebc95c22645cd851
parent1890799b6262fa212d4f22f0e4a6364863fb321a (diff)
downloadguix-da2b2d490bf2873065b5e65d471a50c662bd3234.tar.gz
gnu: Add texlive-hyphen-norwegian.
* gnu/packages/tex.scm (texlive-hyphen-norwegian): New variable.
-rw-r--r--gnu/packages/tex.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2e1e139348..e811f10bc7 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2009,6 +2009,22 @@ T2A, LMC and UTF-8 encodings.")
     ;; Either of these licenses
     (license (list license:lppl1.3+ license:expat))))
 
+(define-public texlive-hyphen-norwegian
+  (package
+    (inherit (texlive-hyphen-package
+              "texlive-hyphen-norwegian" '("nb" "nn" "no")
+              (list "/tex/generic/hyph-utf8/patterns/tex/hyph-nb.tex"
+                    "/tex/generic/hyph-utf8/patterns/tex/hyph-nn.tex"
+                    "/tex/generic/hyph-utf8/patterns/tex/hyph-no.tex")
+              (base32
+               "1fxnf671yz0p3lmdkspna7fjh96br1jy6yf7v17yh4fxwry3s4yz")))
+    (synopsis "Norwegian Bokmal and Nynorsk hyphenation patterns")
+    (description "This package provides hyphenation patterns for Norwegian
+Bokmal and Nynorsk in T1/EC and UTF-8 encodings.")
+    (license (license:non-copyleft
+              "/tex/generic/hyph-utf8/patterns/tex/hyph-no.tex"
+              "FSF All permissive license"))))
+
 (define-public texlive-hyph-utf8
   (package
     (inherit (simple-texlive-package