summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-04 19:26:16 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-10 20:54:00 +0200
commitea0194fc754acb2cf65b52aded692cf793277ed5 (patch)
tree9f95dca9eb9ba296d6b198d5e268c7d2a0b707d6
parent4ae7e1060a8a94852eca3f861c0ce6e1b63b6b63 (diff)
downloadguix-ea0194fc754acb2cf65b52aded692cf793277ed5.tar.gz
gnu: emacs-robe: Don't use unstable tarball.
* gnu/packages/emacs-xyz.scm (emacs-robe)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
-rw-r--r--gnu/packages/emacs-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 1bd3a4e0ae..8a3770df2a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2527,13 +2527,13 @@ mode-line.")
     (version "0.8.1")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append "https://github.com/dgutov/robe/"
-                           "archive/" version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/dgutov/robe.git")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32
-         "1vp45y99fwj88z04ah4yppz4z568qcib646az6m9az5ar0f203br"))))
+        (base32 "0ll7ivxqnglfb0i70ly6qq2yfw9cyi3vq3lmj4s6h6c1c7rm3gcq"))))
     (build-system emacs-build-system)
     (arguments
      '(#:include (cons "^lib\\/" %default-include)))